👉 Comment rendre d'anciens thèmes WordPress compatibles avec les nouvelles versions - IsItWP

WordPress Admin Bar a-t-il besoin d'une liste plus complète?

>

Vous souhaitez donc rendre vos anciens thèmes WordPress compatibles avec les nouvelles versions de WordPress. Avec WordPress 3.0 à nos portes, la compatibilité des thèmes est quelque chose dans l'esprit de beaucoup de gens. C'est assez simple: ne rien faire.

Je fais des thèmes WordPress depuis que WordPress 2.3 est sorti et devinez quoi? Ces thèmes travaille encore aujourd'hui et il n'y a rien que je avoir besoin faire pour qu'ils continuent de travailler avec les nouvelles versions de WordPress.

  • Auront-ils fonctionnalité de commentaire par thread (environ 2,7)? Non, ils ont probablement encore des commentaires de «niveau unique».
  • Va-t-il utiliser post_thumbnails manipuler des vignettes de post (environ 2,9)? Non, mais tous les thèmes n’utilisent pas les miniatures.
  • Auront-ils le nouveau menus de navigation, images d'en-tête et d'arrière-plan personnalisés introduit dans le prochain WordPress 3.0? N'oubliez pas que tous les thèmes n'auront pas besoin d'images d'arrière-plan ou d'en-tête personnalisées.

Je considère que la plupart de ces fonctionnalités sont facultatives. À l'exception peut-être des commentaires threadés ou du nouveau système de menus, de nombreux thèmes n'auront même pas besoin d'être conçus autour d'éléments tels que les miniatures de publication personnalisées ou les images d'en-tête.

Alors s'il vous plaît, arrêtez de vous soucier de savoir si votre thème va se briser lorsque vous mettez à niveau WordPress. Sans vouloir offenser mes amis développeurs de plugins, 99% du temps, WordPress rompt avec une mise à niveau de base, c'est une faute de plugin (et cela est probablement dû à des pratiques de codage de plugins suspectes).

Si un thème a une fonction personnalisée qui est en conflit avec une nouvelle fonction WordPress, la même chose pourrait se produire pour les thèmes. possible. C'est probablement le seul «bug» dont j'ai entendu parler avec une nouvelle mise à niveau de base (et tous les thèmes n'utilisaient pas la fonction get_categories).

Pour être honnête, Je n'ai jamais vu un thème complètement casser, et je ne le ferai probablement jamais. Je serais intéressé d'entendre vos commentaires dans les commentaires, que pensez-vous de rendre les thèmes «compatibles» avec les nouvelles versions? Avez-vous déjà vu un thème en raison d'une nouvelle version de WordPress?

Si vous souhaitez que votre thème WordPress tire parti des nouvelles fonctionnalités qui seront disponibles dès la sortie de WordPress 3.0, cet article contient de bonnes informations sur l’intégration d’arrière-plans personnalisés, d’en-têtes, de menus, etc.

Like this post? Please share to your friends:
Laisser un commentaire

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!: